P2 Plug-in avec accus lithium et bms+

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
Il faut juste que tes soudures par point soient capables de passer 5A par accu.
C'est pas énorme mais c'est le point faible de la soudure par points; les pattes ont intérêt à être en 'pur' nickel, pas en acier nickelé et de section généreuse. Et contrairement à ce que j'ai fait pour mon pack secondaire LG, souder les pattes d'abord dans le sens du courant et juste une en travers pour l'équilibrage et le bms.

Penses-tu mettre des fils-fusible sur un pôle, façon Tesla ?

Je conseille si possible de découper le pack en sous-packs de disons 48 Volts.
Ca fait un stress en moins si on a à intervenir.
Avec si possible un peu de place entre accus pour évacuer la chaleur naturellement ou en forçant.

:jap:
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
en général, je superpose plusieurs bande sur la liaison série pour diminue la résistance. en // il n'y a pas beaucoup de courant si les accu sont homogène.
un petit pack
je vais essayer de mettre un fusible en série au milieu des pack 48v (13s+13s+fuse+13s+13s+6s)
merci encore pour toute ces info.
 
Dernière édition:

Astrix64

Expert
Inscrit
29 Mars 2018
messages
1,317
Score de réaction
654
Localisation
IdF
Véhicule
LS600h
Le problème du fusible est que sa connexion et sa résistivité interne n'est pas négligeable. Il ne faut vraiment pas prendre n'importe quoi. :grin:

Les accus font une vingtaine de milliohms, alors il ne faut pas tout gâcher. 8)
3 accus en //, cela ne fait plus que 7 milliohms....
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
oui tu as raison pour les fusibles
les cellules font plutôt 45mOhms. le pack total fera ~120mOhms (45mOhms*58s/22p)
 

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
Hello,

@Astrix. Un fusible HRC est obligatoire, ce n'est pas négociable. Il n'est là que pour gérer un sérieux court-circuit.

Voici les caractéristiques du fusible dit 100 A que j'ai placé:
Intensité nominale 100 A
Puissance dissipée à 100 A : 8,5 Watts
Cela nous fait une résistance de 0,85 mOhms.
C'est très faible comparé à la résistance interne des accus. Mais ne pas le placer juste sous les accus...

Pour info il accepte 110 A en continu, ou 600 A pendant 1 seconde ou 1000 A pendant 0,1 seconde.

@jc.maquet, attention, les 45 mOhms c'est l'impédance, c'est mesuré en courant variable 1000 fois par seconde. En utilisation "normale" sur route on a une forte composante continue on parle plutôt de résistance et la valeur est différente.
Bien sur cette résistance augmente avec le froid et/ou le vieillissement et/ou le vidage de l'accu.
Il faut aussi ajouter la résistance des câblages/contacteur...


P.S. Il est bien propre ton pack de 18650. :jap:
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
P.S. Il est bien propre ton pack de 18650.
merci mais je suis bien aidé
https://photos.app.goo.gl/YLrf4fWuuCTedQZKA
PS: j'espère que je ne vous ai pas traumatisé !
le soudage de la première face est vraiment sans danger car les accu n'ont qu'un seul pole connecté. aucun risque de court circuit.
pour la seconde face il faut prendre beaucoup de précaution et plutôt faire cela a l'extérieur.
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
l'un d'entre vous aurait il sous la main une photo en bonne résolution du pcb bms2 ?
je n'ai trouvé que des vignettes
merci
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
j'ai reçu les pièces pour le bms2
je viens de finir de le monter, il est presque comme l'original.
par contre, le programmateur traine en route.

https://photos.app.goo.gl/iXkBhLjjiJbScgMi8
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
hello
news
le bms2/+ est programmé et le câble est installé (pour le moment avec le bouchon) sur le connecteur de la batterie HT.
la voiture a l'air d'être contente, RAS.
pfiou ! z'aviez pas dit qu'il fallait démonter la moitié de la voiture pour arriver à ce foutu connecteur. 8)
demain je branche le bms2 clone.

j'ai trouvé un code arduino qui marche pour reprogrammer la tension par défaut des chargeurs flatpack2.
je vais voir si j'arrive a faire un montage can isolé pour pouvoir dialoguer avec tout les chargeurs en même temps.
 

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
Pense à bien sécuriser le connecteur sur le bus can. Rien ne doit abîmer le connecteur ni le débrancher. Sinon c'est mode balistique.

Concernant les eltek, chaque fois qu'on en pilote une on dispose de 14 volts de plage de variation de tension. Deux eltek c'est ok avec nos accus A123 ça fait 28 volts entre accus au niveau bas et accus chargés à fond. Il se peut que tu aies besoin d'en piloter 3. Ca dépend de la plage de tension (au repos) que tu souhaites utiliser pour tes accus. De toute façon on ne dépasse pas la plage 240 volts vers disons 190 volts (Nos A123 étant du lifepo4, il y a un plateau de décharge donc l'amplitude de tension est moindre que par exemple du LiMn). Ne pas s'approcher de 170 volts en charge.

Il n'y a pas de soucis pour reprogrammer les eltek flatpack de manière permanente. Ca marche bien. Si besoin j'ai du code pour dongle canusb. De toute façon c'est dispo sur le forum endless-sphere
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
j'ai branché le bms2, il a l'air de marcher, la led rouge clignote et la voiture fonctionne normalement.
y a t'il moyen de le tester plus sans batterie annexe ?
je charge la batterie d'origine a 240v et j'active le bms2 ?
si j'ai bien compris, le soc devrait rester assez haut jusqu'a la coupure tension basse.
c'est bien ca ?

je suis en train de regarder pour acheter le matos pour le cablage HT.
les cosse sur les fils HT ont l'air en M5, le relais 200A est en M8, le raccord a 3 fils après la capteur hall est plutôt fait en M6 d’après les photo.

je n'ai pas bien compris si le + était côté capteur hall ou de l'autre côté ?
norman avait il fait une description pour le câblage HT ?


merci
 

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
Pour tester bms2:
A mon avis il faut un dongle et un programme pour voir : le soc et les 2 consignes dcl et ccl. Pas besoin d'un dongle rapide.

-il suffit de rouler et de regarder le soc. S'il varie quand on enfonce l'accélérateur et monte à 99% alors bms2 fonctionne. Sauf si on appuie sur le bouton ev auparavent, là il doit le forcer de mémoire à 74% (ou 64 j'ai un doute) même si on enfonce l'accélérateur. Quand on relâche l'accélérateur il revient à la valeur normale, autour de 64% correspondant aux barres bleues ou une verte.
Je n'ai jamais fait attention si ce 99% se voit sur l'afficheur de la prius sous forme de toutes les barres vertes tant qu'on appuie/accélérateur.

-normalement vers 240 volts il limite rapidement le ccl (courant de charge autorisé).

Le circuit HT est simple. Il y a un long câble noir (blindé) qui circule le long de la batterie nimh et qui part du côté passager et va vers le relais. Et il y a un câble court rouge pour l'autre pôle qui va sur un autre relais.
De mémoire le capteur de courant est au niveau du pôle moins, mais c'est juste un capteur hall donc sans contact. Ce capteur doit voir passer le courant de la nimh plus celui du pack additionnel.
Bien sur le câble noir est le pôle moins et le rouge le plus.

Les 3 relais de la prius (Les 2 pôles plus le relais de précharge) ne sont pas faits pour couper du courant en charge.
Donc attention de bien brancher le 2ème pack "directement" sur la nimh, surtout pas après les relais ou à cheval.
Le blindage du câble moins est à mon avis pour éviter de rayonner sur les fils de mesure du bms nimh qui sont parallèles et proches. Peut-être aussi y a-t-il une détection que le blindage est relié au châssis ?

:jap:
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
je suis en panne - triangle rouge

je n'ai rien fait de spécial
juste mesuré la polarité de la tension en remettant donc le fusible capot ouvert
le - est du cote capteur hall
mes 2 fils sont orange mais je vois bien le blindage sur le - et le fil qui va de l'autre cote de la batterie.
je n'ai pas encore touche au câblage ni dévisser une seule cosse
le fusile HT est bien remis. -NON-
juste avant j'avais remis le bms+ le pour tester
j'ai fait cela sans couper le 12v, ca peux jouer ?

bref j'ai retirer le bms2 et remis le bouchon
couper le 12v plusieurs fois

ca ne change pas

j'ai un obdlink mais il ne vois pas de code erreur
lorsque je fait un reset, il y a un msg qui apparaît sur le TDB 'problem'
des idées ?

EDIT:
c'etait juste le coupe circuit HT qui n'était pas glissé vers le bas
désole pour l'alerte
 

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
En tout premier verifier que le fusible orange est remis, ça se fait en trois temps:
-enfiler
-faire pivoter le levier
-faire coulisser le levier vers le bas

C'est le 3ème temps qui est souvent oublié. SI tu crois que c'est bon recommence jusqu'à en être certain.

Comme il y a un micro-contact au niveau de ce levier, le système hybride sait si le 3ème mouvement a été fait.


En retirant/remettant bms2 je présume que tu l'as fait contact coupé, donc en power off.
Le câblage de bms2 coupe l'alimentation (je devrais dire les alimentations) du bms nimh. Le bouchon permet de le rétablir. C'est fait exprès.

Fuse_plug_3temps.jpg
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
le clone du bms2 marche bien.
lorsque le modem électrique est activé, le soc monte bien 99% lors de l'accélération et coupe quand la batterie d'origine arrive en dessous de 200v. (ce qui évidement arrive assez vite.)
quand le mode électrique est désactivé, la voiture retrouve son comportement habituel.

le seul truc qui est bizarre, c'est que la led qui devrait correspondre a l'activation du gros relais est toujours allumée.
il faut encore que je vérifie si la sortie pour le gros relais commute bien.

j'ai mis tous les setting du bms2 sur off
J7-8: mode //
J9: lithium mais non A123
P1-2-3: tension la plus basse 200v
P4: contactor power when ready and phev selected

on vient de finir d'assembler plus de 3000 pièces de support de 18650, quelques cellules et de préparer des câbles HT
comme on part au sports d'hivers la semaine prochaine, je préfère éviter de toucher au connections HT pour le moment, le triangle rouge m'ayant un peu stressé la dernière fois.
 

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
Un très gros bravo pour ce bms2 ! :ouioui:

Pour les commutateurs, seule la doc peut t'aider, avec nos bms+ on ne les a pas. Le contacteur entre nimh et lithium est dans mon cas toujours actionné dès qu'on est en power on (même dès le mode accessoire 1), j'ai juste inséré un interrupteur qui ne sert pas, au cas où. Donc ce n'est pas bms+ qui pilote ce contacteur.
Dès qu'on recharge les accus lithium, le contact est coupé donc le contacteur est ouvert. IL FAUT penser à ne pas mettre le contact pendant la recharge, ce qui ne serait pas dangereux pour les nimh s'ils ne dépassent pas environ 236 volts. Ne jamais recharger la nimh sans ventilateur à partir de ce seuil. Trop risqué (déséquilibre des cellules possible et emballement thermique avec expansion des cellules ... dramatique).
Le suprême raffinement empêche de rouler si on est branché sur une prise pour une raison évidente de risque d'arrachement de la prise de son socle.

Est-ce que tu fais des packs de disons 48, maxi 60 volts ?
Petit détail les gaines HT sont de couleur orange. Le jaune est certes fort joli :-D
 

m8mat

Expert
Inscrit
1 Juin 2011
messages
557
Score de réaction
738
Localisation
Limoges
Véhicule
Prius 2 plug-in 4,5kwh
Superbe boulot ! Impressionnant ! Bravo !!

De mon côté tout marche impec, j'approche des 260 000 kms, dont 120 000 avec le pack 4,5 kwh. :-D

Il commence un peu à fatiguer par contre, j'ai perdu environ 20/25% d'autonomie par rapport au tout début (je pouvais exploiter 17,5Ah régulièrement alors qu'aujourd'hui je peine à en consommer 14).:-?

Les accus me servant par contre avec le gros convertisseur type enginer ne fatiguent pas (3kwh) : c'est assez logique, ils ne sont utilisés que dans une plage d'intensité qui leur convient, et sans grosses recharges régulières.:jap:

Bon courage pour la suite, car c'est un véritable régal d'utiliser sa prius ainsi ! :jap::grin:
 

jc.maquet

Confirmé
Inscrit
2 Janv. 2009
messages
40
Score de réaction
18
Localisation
waterloo
Véhicule
Prius 2
merci, je note toujours bien tes recommandations !
pour le jaune on dira que je suis daltonien ;-)

voila ce que j'ai trouvé sur la copie du site du norman:
+12v and LED- used to drive a dash mounted LED . Used with Enginer to show 1 converter working (flashes) or 2 converters working (on solid) Used with parallel packs to show contactor engaged.

je fais bien 4 pack de 48v(13s) et un de 24v(7s) pour arrive a 59s
ca me permet d'utiliser 4 flatpack2 et une alim 12v de server (241v a 4.1 par cell)
mais je pense rester a 4v du moins au début.
je trouvé un IC canbus isolé () pour piloter les flatpacks. cela devrait être assez facile.
au fait, y a t'il moyen d'ajuster la valeur de la limitation de courant sur le flatpack HE ?
ou faut il jouer avec la tension pendant la charge ?

pour le bms 2, j'ai encore 4 autre pcb dispo ; je veux bien aussi souder les smd si besoin ou refaire un boitier complet. avis aux amateurs.
 

planétaire

Expert
Inscrit
4 Fév. 2008
messages
8,807
Score de réaction
4,883
Localisation
Caldera d'Ecouves
Véhicule
Prius 2 plugin 13,5 kWh Full Li
Oui, il existe des transceiver isolés, par exemple l'iso1050 que j'ai déjà testé sur un arduino due et une eltek.
Mais attention cela veut dire autant de bus can que d'alim pilotées car on n'isole que le "pilote", pas l'alim qui est pilotée. Pour n'avoir qu'un seul bus can il faudrait pouvoir remplacer le transceiver de chaque eltek par un isolé. Cela a été envisagé sur le forum véhicules électriques mais le transceiver en question est mal placé dans l'eltek et bien sur est en cms.

On peut limiter l'intensité de manière temporaire mais je ne trouve pas que cela fonctionne bien au démarrage. On peut avoir un dépassement au début. Ensuite c'est ok. Les bornes publiques acceptent très facilement cette sur intensité. Les disjoncteurs domestiques aussi.
Bien sur à la place on peut jouer avec la limitation de tension, c'est ce que je faisais au début. Il faut monter lentement la tension car l'intensité démarre disons "rapidement" une fois atteint un seuil.

Je ne connais pas de commande pour limiter l'intensité de façon permanente.
 
Pages vues depuis le 20 Oct 2005: 276,595,747
Haut Bas